Вот попробуйте прописать другой шаблон.
А лучше, еще раз повторюсь, попытайтесь развернуть ShopModxBox и посмотреть там как все работает.
Имеется другой шаблон tpl
в логах ничего нет, что у modx что на сервере
Смотрите пп 2 и 3.
У вас шаблон foo.tpl имеется? Скорее всего нет, и соответственно возникает критическая ошибка. Но так как вы не указываете вывод ошибок на странице, то они у вас улетают в лог. Ищите логи и в них конкретную ошибку, или выводите логи на страницу. Экстрасенсы на самоизоляции.
Даже при выводе [[!smarty?tpl=`foo.tpl`]] всё равно выдает 500
1. Где-то я писал, что лишние манипуляции с .php больше не требуются. Создаете обычный шаблон и в любом месте прописываете [[!smarty?tpl=`foo.tpl`]]
2. В core/config/config.inc.php можете прописать
ini_set('display_startup_errors', 1); error_reporting(E_ALL ^E_NOTICE);
должно помочь с тем, чтобы сообщения об ошибках выводились на саму страницу.
3. Попробуйте сначала развернуть отдельно ShopModxBox. Там все на смарти, изучите там как в общих чертах все работает, а после уже на своем сайте делайте.
Сделал по инструкции шаблон main с статическим файлом assets/templates/main.php
Создаю страницу, прикручиваю шаблон, делаю Тип ресурса с php форматом
Создаю в папке assets/templates/default - 3 файла формата *.tpl - для теста прописываю там простой текст текст
перехожу на страницу и выбивает сходу ошибку 500
не могу понять на каком этапе допустил ошибку, сделал вроде всё правильно.
Кэш чистил, права проверил..
@ Fi1osof да действительно, извиняюсь, что-то на моей стороне, права выставляю но ничего не меняется.
Нашел причину в пути к ядру в таблице modx_workspace, поменял на новый путь и всё ок
@EMAKASS, хотя проект и не развивается, но во всяком случае не похоронен.
Сам попробовал сейчас на modhost на последней версии MODX установить, все устанавливается http://joxi.ru/DmBJ1RaCzaOJjm
Вероятней всего проблема где-то на вашей стороне (может нет прав на запись файлов или типа того). Посмотрите логи, хотя при установке пакетов MODX практически ничего внятного в логи не записывает, к сожалению.

@edit, сайт не "все". Просто пользователи не хотят ничего писать и спрашивать, видимо.
Невозможно установить пакеты, пишет ошибка. "Невозможно установить пакет с подписью: modxsmarty-1.0.3-beta" и так же с пакетом phptemplates-1.5.2-beta. Проект загнулся?
MODX Revolution 2.7.2-pl